News Briefs

Vulnerable may need COVID-19 booster shots
June 5, 2021 - 9:38 pm

People most vulnerable to Covid-19 could require a booster of the BioNTech/Pfizer vaccine later this year, according to scientists who said the shot elicited a lower antibody response against the Delta variant first identified in India.

A study by researchers at the Francis Crick Institute and UCLH Biomedical Research Centre found that levels of neutralising antibodies in recipients of two shots of the vaccine were, on average, more than five times lower against the Delta variant than the original strain that emerged in Wuhan, China.

Source: Financial Times

News Briefs

Trivia

The Mahatma, an anti-vaxxer?

We chronicle the diaries of Mahatma Gandhi to learn about his personal views regarding vaccines.

Twitter Handle

Copyright © 2021 I Daily Remedy